Befehle

Nach der Referenz der Werkzeuge von SuperReport Pro folgt nun die Übersicht über die Befehle. Es gibt vier Menüs - Ablage, Bearbeiten, Optionen und Datenbank. Die am häufigsten verwendeten Befehle finden sich in den ersten beiden Menüs, da sich in «Optionen» und «Datenbank» eher nur einmal zu verwendende Grundeinstellungen befinden.

File

File – New

Dieser Befehl erzeugt ein neues, leeres Formular. Für unsere Zwecke ist dieser Befehl nicht zu gebrauchen, da es viel zu aufwendig ist, von einem leeren Formular ausgehend einen Report zu erzeugen.

File – Open

Mit diesem Befehl öffnen Sie ein Formular, was sich nicht in der profacto - Datenbank befindet, sondern extern auf der Festplatte gespeichert ist. Dementsprechend erscheint dann ein Dialog, der Ihnen erlaubt, das Formular auszuwählen. Unter Windows müssen Formulare die Endung «.SRP» tragen.

File – Close

Diesen Befehl benötigen Sie nicht.

File – Save

Dieser Befehl speichert das aktuell in Bearbeitung befindliche Formular in der profacto - Datenbank. Dadurch ist sichergestellt, dass immer nur die profacto -Datenbank gesichert werden muss und keine weitere Datei. Am unteren Rand des Fensters sehen Sie die Gruppe und den Namen des Formulars, unter dem es in der Datenbank gesichert wird.

File - Save As...

Mit diesem Befehl wird das Formular extern auf die Festplatte gesichert. Sie nutzen diesen Befehl, um das Formular zur Weitergabe an andere abzuspeichern. Sie können es dann auf Diskette oder per Email versenden. Wenn Sie als Macintosh-Anwender ein Formular sichern, sollten Sie ihm auch die Endung «.SRP» geben, damit auch Windows-Anwender das Formular einlesen können.

File - Export...

Hiermit drucken Sie den aktuellen Report in eine Textdatei. Diese Funktion kann nützlich sein, wenn Sie einen Export speziell aufbereiteter Daten vornehmen wollen. In der Regel nutzen Sie den Befehl aber nicht.

File - Preview...

Mit diesem Befehl erhalten Sie eine Bildschirmvoransicht des aktuellen Reports. Sie können damit ohne Papierverbrauch testen, ob Ihr Formular sich im Druck wie gewünscht präsentiert. Unter Windows erfolgt die Vorschau im Microsoft XPS Document Viewer, auf dem Macintosh im Programm Vorschau

File - Page Setup...

Mit diesem wichtigen Befehl konfigurieren Sie das Formular auf den gewünschten Drucker und die gewünschte Papiergröße. Nach Anwahl des Papierformats und des Druckers kann SuperReport rückfragen, ob die Objektpositionen angepasst werden sollen. Sie sollten diese Rückfrage immer mit Adjust bestätigen, damit die Positionierung der Felder in Bezug auf die Blattränder erhalten bleibt.

File - Print Job Setup...

Dieser in SuperReport Pro 3.0 neue Befehl ermöglicht Ihnen, all die Einstellungen vorzunehmen, die im Druckdialog vorgenommen werden. Durch das Bestätigen der Einstellungen wird jedoch kein Druck ausgelöst, sondern nur die Einstellungen gespeichert.

File - Print...

Mit diesem Befehl wird das Formular auf den aktuell gewählten Drucker gedruckt.

File - Zoom Window

Damit wird der Report, in dem das Formular bearbeitet wird, in einem eigenen Fenster dargestellt. Das ist manchmal praktisch, wenn man besonders grosse Reports bearbeiten will. Durch Klick auf das Schliessen-Feld gelangen Sie zurück in den Reportdialog von profacto.

Edit

Edit - Undo bis Select All

Die ersten 5 Befehle im Menü Bearbeiten sind die üblichen Standardbefehle, die sich als sehr nützlich erweisen können, wenn man eines oder mehrere Felder kopieren oder ausschneiden will. Die Befehle können auch beim Editieren von Skripts zu Feldern und Bereichen angewendet werden.

Mit dem Befehl «Einfügen» können Sie auch Bitmap-Dateien aus anderen Anwendungen importieren, also Logos und dergleichen. Damit die Bitmap im Druck optimal aufgelöst erscheint, sollte sie viermal so groß sein wie im Ausdruck. Ist die Graphik eingefügt, können Sie diese mit der Maus oder über den Befehl «Objekt positionieren» verkleinern.
Klicken Sie die Graphik doppelt, erscheint der untenstehende Dialog (der auch schon weiter oben beim Bild-Werkzeug besprochen wurde:

Stellen Sie hier die Option «Scaled (Proportional, Centered)» ein, so wird die Graphik immer in der richtigen, originalen Proportion dargestellt.

Edit - Duplicate Object

Im Gegensatz zu «Kopieren» und «Einfügen» können Sie mit «Duplizieren» markierte Felder direkt kopieren und gleichzeitig um einige Pixel versetzt wieder einfügen. Dadurch bleibt der Inhalt der Zwischenablage erhalten.

Edit - Modify Object...

Ob Sie nun ein Objekt im Formular doppelklicken oder diesen Befehl aufrufen - der Bearbeitungsdialog für das betreffende Objekt - Variable, Feld, Text oder Zeichnungsobjekt - erscheint am Bildschirm.

Edit - Position Object...

Will man ein Formular erzeugen, das sehr exakt äußeren Spezifikationen genügen muss, weil beispielsweise Text in ein Formblatt gedruckt werden muss, dann hilft der Befehl «Objekt positionieren». Es erscheint der untenstehende Dialog, in dem Position und Größe eines Felds, einer Variablen, eines Rechtecks etc. auf den mm genau bestimmt werden können. Während dies für die Position des Objekts sehr sinnvoll ist, empfehlen wir, die Objektgröße eher über die Tastatur einzustellen, da die Maßeinheit “mm” hierfür nicht exakt genug ist.

//Screenshot ObjektPositionieren.jpg

Edit - Modify Section

Dieser Befehl führt zum selben Ergebnis wie das Doppelklicken der betreffenden Bereichsmarke im Formular. Es erscheint der untenstehende Dialog:

Seite Allgemein

Auf der Seite «General» stellen Sie ein, wann der Bereich gedruckt werden soll und was nach dem Druck passieren soll. Wahlweise kann der Bereich in den Section Options

  • immer, d.h. für jeden Datensatz
  • nur auf der ersten Seite
  • nur auf den Folgeseiten
  • oder nur bei der Änderung eines Datenfelds oder einer Variablen

gedruckt werden. Falls es sich um Wertänderungen handelt, so bietet profacto bestimmte Variablen an, die ihren Wert zum passenden Zeitpunkt ändern oder man bezieht sich auf Datenfelder, die ihren Wert geeignet ändern, wie beispielsweise Projekt- oder Positionsnummern. Diesen vierten Fall nutzt man speziell für Zwischenüberschriften und Zwischensummen. Mehr dazu erfahren Sie weiter unten bei den Ausführungen zum Druckablauf.

Neu kann nun festgelegt werden, ob der Bereich auf der ersten, zweiten oder der letzten Seite gedruckt werden soll. Dies kann für spezielle Formblätter hilfreich sein.

Die Option Print at bottom ist hilfreich, wenn ein Summenbereich nicht direkt im Anschluss an den Body gedruckt werden soll (also den sich pro Datensatz wiederholenden Druckbereich), sondern am unteren Seitenrand, direkt über dem Fussbereich.

Bei den Page Breaking Options können Sie zuerst einmal festlegen, ob der Bereich als Ganzes auf eine Seite passen muss, um gedruckt zu werden, oder ob er auch teilweise gedruckt werden kann. Diese Option ja nach zu druckenden Daten ein- oder ausgeschaltet sein. Drucken Sie beispielsweise längere Texte, so kann der Bereich auf mehrere Seiten verteilt, als teilweise gedruckt werden. Handelt es sich um einen Summenblock, will man diesen kaum unterteilen lassen, daher sollte der Bereich immer komplett auf einer Seite bleiben.

Weiter könnte der Bereich entweder

  • ganz normal auf der aktuellen Seite
  • nach einem Seitenumbruch
  • vor einem Seitenumbruch
  • oder nur dann, wenn mindestens x mm druckbarer Platz frei sind

gedruckt werden. Die dritte Option ist wichtig, wenn man beispielsweise ein Angebotsanschreiben auf einem Deckblatt drucken will, bevor dann auf den folgenden Seiten die eigentlichen Positionen gedruckt werden. Die letzte Option ist sehr praktisch, wenn man erreichen will, dass von einem Datensatz mit mehrzeiligem Text mindestens zwei bis drei Zeilen gedruckt werden, bevor ein Seitenwechsel möglich ist. Wäre dieser Platz nicht frei, würde sofort eine neue Seite begonnen werden. Dazu müssen Sie lediglich einstellen, dass z.B. im Datenbereich mindestens 20mm freier Platz vorhanden sein müssen, damit der Druck des Bereichs begonnen wird.

Seite Script


Auf der Seite Skript können Sie das Skript hinterlegen, was beim Druck des Bereichs ausgeführt werden soll. Hierbei muss beachtet werden, dass das Skript bereits dann ausgeführt wird, wenn versucht wird, den Bereich zu drucken. D.h. dass Berechnungen bereits ausgeführt werden, selbst wenn dann der Bereich tatsächlich erst auf der nächsten Seite gedruckt wird. Dieser Effekt kann sich besonders dann sehr ungewünscht auswirken, wenn Zwischensummen auf Basis von Werten berechnet werden, die dann doch erst auf der nächsten Seite gedruckt werden.

Edit - Position Sections...

Dieser Befehl hat nur kosmetische Auswirkungen: Die Bereichsmarken können mit diesem Befehl neu angeordnet werden, wahlweise alle untereinander links oder rechts oder mit/ohne Überlappung versetzt. Manchmal ganz praktisch, wenn man eine Orientierung darüber haben will, welche Bereiche im Formular vorhanden sind.

Edit - Add Sections...


Mit diesem Befehl können Sie zentral einstellen, welche Bereiche im Formular sichtbar sind. Auf den Druck selbst hat dies noch keine Auswirkungen, da Sie einen sichtbaren Bereich dennoch für den Druck deaktivieren können. Ganz genau wird lediglich die betreffende Bereichslinie ein- oder ausgeblendet, wenn Sie einen der Bereiche in der Liste aktivieren. Für ein korrektes Formular sind in Bezug auf die Bereiche einige Regeln zu beachten:

  • Die Bereiche Kopfzeile, Datenteil und Fußzeile sollten immer aktiv sein.
  • Die Druckbedingung für «Kopf x» und «Umbruch x» sollten identisch sein.
  • Existiert «Kopf x», sollte auch «Umbruch x» aktiv sein.

Mehr zu den Bereichen erfahren Sie noch weiter unten.

Praktischerweise bietet SuperReport nun an, dass beim Hinzufügen eines Headers auch gleich der Footer hinzugefügt werden soll. Weiterhin können Sie gleich die Umbruchsbedingung festlegen, auch wenn das hinterher in der Bereichsbearbeitung ebenfalls erfolgen kann.

Edit - Report Options...

Die Report-Optionen sind völlig neu in SuperReport 3.0. Folgendes ist hier einstellbar

  • Reportname - geben Sie dem Report hier einen sprechenden Namen
  • Definieren Sie hier, ob der Body-Bereich mehr als eine Spalte haben soll. Dies kann für manche spezielle Anwendungen interessant sein, beispielsweise für Etiketten.
  • Die Option Calculate number of pages führt dazu, dass der Report zweimal gedruckt wird. Dafür ist die Variable SRPages beim eigentlichen Druckablauf dann verfügbar und stellt die Gesamtzahl der Seiten im Report bereit.
  • Die Einstellung Grid size erlaubt Ihnen, den Rasterabstand zu definieren. 28,34650 Punkte entsprechen einem Zentimeter.
  • Die Page margins definieren den Seitenrand. Diesen sollten Sie nicht verändern, weil er durch den Druckertreiber festgelegt wird.
  • Das Proximity Limit legt fest, ab welcher Nähe ein Objekt mit den Führungslinien (Guides) oder dem Raster (Grid) einschnappt, falls das Snapping angeschaltet ist.

Edit - Select Objects

Mit diesem Dialog können Sie gezielt mehrere Objekte selektieren, selbst dann, wenn sie hinter anderen Objekten verborgen sind. Gleichzeitig sehen Sie so auf einen Blick, in welchem Bereich welche Objekte liegen. Um mehrere Objekte zu selektieren, halten Sie die Ctrl/Cmd-Taste gedrückt.

Object

Object Menü

In diesem Menü finden Sie Befehle, mit denen die Objekte im Report direkt modifiziert werden können.

Object - Bring To Front

Die nächsten vier Befehle drehen sich um die Druckreihenfolge von Objekten. Stellen Sie sich einfach jedes Objekt im Formular wie ein Stück Papier vor, das Sie auf eine große Fläche legen. Das Stück Papier, was zuunterst liegt, ist der Fläche am nächsten, das, was zuoberst liegt, ist am weitesten von der Fläche entfernt. Für die Druckreihenfolge gilt das Gleiche: Das Objekt, welches am weitesten hinten liegt, wird zuerst gedruckt. Die Druckreihenfolge ist immer innerhalb eines Bereichs von Bedeutung, und zwar einerseits für die Berechnung von Variablen und andererseits für die Ermittlung der korrekten Höhe von Objekten, die mit variabler Höhe gedruckt werden. Die Position eines Objekts hat daher nichts mit dem Druckzeitpunkt zu tun. Selbst, wenn ein Objekt sehr weit oben im Bereich positioniert ist, kann es sehr spät gedruckt werden, wenn es ganz nach vorne gebracht wurde.

Kommt es beim Druck daher nicht zu den gewünschten Ergebnissen, sollten Sie die betreffenden Objekte einfach mal nach vorne oder hinten bringen. Wird beispielsweise ein Feld über ein anderes gedruckt, so sollte das überdruckende Feld einfach nach vorne gebracht werden.

Kommen wir daher zum ersten der vier in diesem Zusammenhang stehenden Befehle. «Ganz nach vorne» bewirkt, dass das markierte Objekt innerhalb des aktuellen Bereichs zuletzt gedruckt wird.

Object - Bring Forwards

Mit diesem Befehl wird das markierte Objekt (es können auch mehrere sein) um eine Position in der Druckreihenfolge nach hinten gesetzt.

Object - Send To Back

Mit diesem Befehl wird das markierte Objekt in der Druckreihenfolge ganz nach hinten gesetzt.

Object - Send Backwards

Mit diesem Befehl werden die markierten Objekte in der Druckreihenfolge um eine Position nach hinten gebracht.

Object - Group

Um mehrere Objekte, die zusammengehörig sind, vor unabsichtlichen Änderungen zu schützen, können sie gruppiert werden. So können sie auch gemeinsam verschoben werden.

Object - Ungroup

Dieser Befehl löst eine Gruppe von Objekten wieder auf in einzelne Objekte.

Object - Lock

Mit diesem Befehl kann ein Objekt gesperrt werden. Die Sperre verhindert nur, dass das Objekt in der Grösse verändert wird, alles Weitere ist noch möglich. Erst, wenn Sie das Objekt bearbeiten und dort bei Lock angeben "Lock (not selectable)", wird das Objekt komplett gegen jegliche Änderung gesperrt. Um die Sperre wieder aufzuheben, müssen Sie das Objekt über den Befehl "Select objects" selektieren.

Object - Unlock

Hebt die Sperre für das markierte Objekt wieder auf.

Object - Align Objects

Hier finden Sie die 6 Optionen, um markierte Objekte anzuordnen:

  • Horizontal
    • Links
    • Mittig
    • Rechts
  • Vertikal
    • Oben
    • Mittig
    • Unten

Object - Hide

Damit können die markierten Objekte versteckt werden. Auch versteckte Objekte werden noch gedruckt.

Object - Show All

Alle versteckten Objekte werden wieder angezeigt.

Object - Font Name bis Vertical Text Alignment

Die hier aufgeführten Befehle erlauben es, die markierten Objekte direkt zu formatieren, genau so, wie es auch über die Werkzeugleiste funktioniert.

Object - Increase Line Spacing

Hiermit ist der Zeilenabstand für Textobjekte veränderbar. Mit diesem Befehl wird er vergrössert. Sie können den Zeilenabstand auch direkt in den Einstellungen des jeweiligen Objekts anpassen.

Object - Decrease Line Spacing

Dieser Befehle verringert den Zeilenabstand.

Object - Auto Wrap

Aktivieren Sie diese Option, wenn Text umgebrochen werden soll, wenn er breiter als das Objekt ist, in dem er gedruckt wird. In der Regel wollen Sie dieses Verhalten immer haben.

Object - Adjust Object Size by Style

Dieser Befehl wurde auf Wunsch von extragroup in SuperReport 3 aufgenommen. Bisher war es so, dass beim Ändern von Schrift oder Schriftgrösse die markierten Objekte auf ihre normale Grösse verändert wurden, auch solche, die auf 1 oder 2 Pixel in der Höhe minimiert waren. Dies ist jetzt nicht mehr so, was sehr praktisch ist. Durch den Befehl kann nun erzwungen werden, dass die markierten Objekte wieder auf die Grösse verändert werden, die notwendig ist, um mindestens eine Zeile sichtbar zu drucken, basierend auf der aktuellen Schriftgrösse.

View

View - Menü

In diesem Menü finden Sie ausschließlich Befehle, die als Schalter konfiguriert sind, d.h. vor jedem Befehl sehen Sie ein Häkchen, wenn die Option aktiv ist.

View - Physical Page

Die nächsten beiden Befehle sollten Sie in der Regel nicht anrühren. Sie dienen dazu, um das Formular wahlweise als komplettes Blatt Papier oder nur innerhalb seiner bedruckbaren Grenzen zu betrachten. Nutzen Sie die erstere Option und lassen Sie diese einfach unverändert. Vorteil ist hier, dass man das Blatt weitgehend in Originalgröße sieht und besser abschätzen kann, wie viel Platz denn tatsächlich zum Papierrand ist.

View - Printable Area

Siehe oben.

View - Show Ruler

Das Lineal, welches Sie am unteren und rechten Rand des Formulars sehen, kann mit diesem Formular eingeblendet oder ausgeblendet werden.

View – Ruler Units

Mit diesem Befehl können Sie zwischen den Einheiten Zoll, mm und Pixel wählen. Lassen Sie die Linealeinheit ein mm stehen.

View - Show Grid

Das Raster bezieht sich auf die gewählte Linealeinheit und erlaubt Ihnen, die Position von Objekten einfacher zu bestimmen. Bei vielen Objekten im Formular kann es jedoch auch störend sein, denn blenden Sie es mit diesem Befehl aus.

View - Snap to Grid

Ist diese Option aktiv, fangen sich Objekte beim Verschieben mit der Maus am Raster, sobald sie in der Nähe des Rasters sind. Wie nah "nah" ist, wird in den Reportoptionen eingestellt (Edit-Menu).

View - Show Guids

Hilfslinien erhalten Sie, wenn Sie mit der Maus in ein Lineal klicken und die Maus dann nach links bzw. oben ziehen. Hilfslinien sind nicht magnetisch, bieten jedoch eine weitere Möglichkeit, Objekte im Formular aneinander auszurichten.
Mit diesem Befehl können Sie die Hilfslinien ein- oder ausblenden.

View - Snap To Guides

Ist diese Option aktiv, fangen sich Objekte beim Verschieben mit der Maus an den Hilfslinien (Guides).

View - Lock Guides

Sind die Hilfslinien fixiert, so können Sie sie nicht mehr unabsichtlich mit der Maus verschieben. Aller Erfahrung nach ist es oft schwierig genug, eine Hilfslinie überhaupt zu verschieben, daher ist der Befehl meist nicht besonders wichtig. Wenn Sie tatsächlich mal eine Hilfslinie verschieben wollen und Sie treffen diese nicht mit der Maus, so bewegen Sie den Mauszeigen einfach über den Bildschirmrand hinaus. Dadurch wird die Maus neu positioniert und meist sitzt der Mauszeiger dann auf dem richtigen Bildschirmpunkt, um die Hilfslinie zu treffen.

View - Show Sections

Sehen Sie in einem Formular einmal den Wald vor lauter Bäumen nicht mehr, können Sie mit diesem Befehl die Bereichslinien ausblenden. Dies erhöht die “Lesbarkeit” des Formulars deutlich. Wenn Sie Objekte senkrecht verschieben, sollten Sie die Bereiche wieder einblenden, damit ein Objekt nicht versehentlich auf eine Bereichslinie kommt.

View - Lock Sections

Wollen Sie sicherstellen, daß Sie Bereichslinien nicht aus Versehen verschieben, dann fixieren Sie die Bereiche mit diesem Befehl.

View - Show Margins

Dieser Befehl sollte immer aktiviert sein, da Sie so die roten Linien für die Ränder des bedruckbaren Bereichs sehen. Nur so können Sie feststellen, ob einzelne Druckobjekte über den bedruckbaren Bereich hinausragen.

View - Show Object Borders

Dieser Befehl sollte einfach nicht benutzt werden. Die Objektrahmen sind die dünnen schwarzen Linien, mit denen Felder und Variable umrahmt werden und sind für die Orientierung durchaus sinnvoll.

View - Object Content-Untermenü

Wird diese Option aktiviert, so wird anstatt des Objektnamens eine Zahl eingeblendet, die für die Position im Druck steht. Diese Option ist sehr sinnvoll, wenn man ganz genau wissen will, in welcher Reihenfolge Variablen und Datenfelder gedruckt werden. Weitere Optionen:

  • Format, falls definiert
  • Grösse in Einheiten des Reports
  • Wert - sehr sehr praktisch, falls der Report bereits einmal gedruckt wurde. Dann sehen Sie hier die letzten Werte aus dem Druck.
  • ID - die interne ID des Objekts
  • Alias - Schalten Sie diese Option ein, so wird bei Datenfeldern anstelle des Feldnamens der komplette Name, bestehend aus Dateiname und Feldname angezeigt

View - Vergrösserungsoptionen

Die Vergrösserungsoptionen erlauben es nun, den Report nicht nur in der bisherigen Auflösung zu sehen und zu bearbeiten, sondern auch in augenfreundlicheren Vergrösserungen.

Original Size

Die bisherige Grösse, die für erfahrene Anwender nach wie vor gut geeignet ist, weil man sehr viel vom Formular auf einmal sieht.

Zoom To 100%

Entspricht exakt den Abmessungen des gedruckten Reports.

Zoom In

Vergrössert die Darstellung weiter.

Zoom Out

Verkleinert die Darstellung wieder.

View - Headers/Footers For - Untermenü

Mit dieser Befehlsgruppe können Sie die Darstellung der Bereiche gezielt einschränken, wahlweise auf:

First Page

Nur die Bereiche, die auf der ersten Seite gedruckt werden

Second Page

Die Bereiche, die auf der zweiten Seite gedruckt werden

Last Page

Die Bereiche, die auf der letzten Seite gedruckt werden

All Pages

Alle Bereiche darstellen.

Database

Database - Menü

Database - Report Table/Iterations



Mit diesem Befehl wird die Datei festgelegt, auf deren Basis der Druck erfolgt. In profacto gibt es einige Druckdateien, die profacto speziell für den Druck aufbereitet und für die die beiden nachfolgenden Befehle dann nicht weiter berücksichtigt werden müssen:

  • Dokumente: Wird verwendet für den Druck von Angebot bis Rechnung und Gutschriften
  • Auftrag: Für freie Auftragslisten (Projektlisten)
  • Positionen: Für freie Positionslisten
  • Rechnungen: Für Mahnungen
  • Stückliste: Für Stücklisten
  • Material: Für Materialbedarf und Materiallisten
  • Beschichtungen: Für Beschichtungslisten
  • Vorgabezeiten : Für den Druck von Vorgabezeiten zu Stücklisten

Die anderen drei Optionen werden Sie im Zusammenhang mit profacto nicht benötigen.

Database - Select Records...

Wollen Sie sich einen Report auf einer Selbstdefinierten Menge von Datensätzen zusammenstellen, so können Sie in diesem Dialog, den Sie von der Recherche-Funktion des Suchdialogs bereits kennen, die gewünschte Menge an Datensätzen zusammenstellen.

Database - Order Selection...

In diesem Dialog können Sie die zu druckende Auswahl an Datensätzen sortieren lassen. Alternativ, und oftmals einfacher anpassbar, lässt sich die Sortierung auch im Startskript vornehmen (siehe unten).

Database - Select Printing Section


Mit diesem Befehl legen Sie fest, welche Bereiche in den Druck aufgenommen werden sollen. Dies ist der zentrale Weg - alternativ können Sie auch in den Eigenschaften jedes Bereichs einzeln einschalten, ob dieser gedruckt werden soll.

Database - Scripts Untermenü

Jedes Formular besitzt drei feste Skripts, die zu bestimmten Zeiten ausgeführt werden können. In profacto benutzen wir in der Regel nur das erste und das letzte der drei Skripts:

Kopf-Skript / Start-Script

In diesem Skript, welches exakt einmal vor dem Druck des Formulars ausgeführt wird, sollten eventuell nötige Suchabfragen, Sortierungen und vor allem die Initialisierung von Variablen durchgeführt werden.

Datenteil-Skript / Body-Script

Dieses Skript wird jedem Druck des Datenteils ausgeführt. Sie können jedoch auch an den Bereich «Datenteil» ein Skript hängen.

Ende-Skript / End-Script

Dieses Skript wird einmal zum Abschluss des Formulardrucks ausgeführt. Es empfiehlt sich, hier all die Datensätze wieder freizugeben, die außerhalb der normalen Datensätze per «Query» ausgewählt wurden. Dazu nutzen Sie folgende Syntax:

UNLOAD RECORD([Dateiname])

Die Freigabe von Datensätzen mit «UNLOAD RECORD» ist speziell im Netzwerk sehr wichtig, um zu verhindern, dass nicht mehr in Benutzung befindliche Datensätze immer noch gesperrt sind.

  • No labels